FR - Viperr X alpha - Retour test et proposition modif thème firefox


#1

Hello tous,

Après avoir testé un tout petit peu la dernière alpha de Viperr je voulais vous faire part d’un tout petit bug et d’une proposition de modification du thème firefox (certains éléments de firefox restés blancs piquent un peu).

Si je trouve d’autres bugs ou modifications sympathiques je les posterai ici ! :slight_smile:

Premièrement je vous propose une modification sur userContent.css afin d’avoir la page nouvel onglet sombre :

    @-moz-document url(about:newtab) {
        .activity-stream {
            background-color: #333333 !important;
        }
        .top-sites-list .top-site-outer > a {
            color: #dddddd !important;
        }
        .tile {
          filter: grayscale(42%) !important;
          opacity: .9 !important;
        }
        .top-site-outer .title span {
          color: #aaaaab;
        }
        @media (min-width: 1280px) {
          .activity-stream main {
            width: : 989px !important;
          }
        }
    }

Ce qui donne :
VP_darktheme

J’ai également trouvé un petit bug. La première fois qu’on fait “Ouvrir un terminal ici” dans thunar, aucun terminal par défaut n’est configuré. Il est demandé de choisir un programme par défaut et seul “Terminal X” (xterm) apparaît dans la liste. Il faut choisir manuellement en tapant terminator. C’est pas grand chose ^^

A plus !


#2

Merci de ton retour. On regarde ça au plus vite mais si tu a un lien montrant le bug cela serait tip top


#3

Alors j’ai pu remarquer dans le dot file de thunar uca.xml que Thunar utilise exo d’xfce pour le terminal par défaut. Quand on fait un exo-preffered-applications, on voit qu’aucun terminal n’est proposé par défaut et que seul “Terminal X” est proposé.

Capture2

Capture3

Terminator ne semble pas connu comme terminal.
J’ai cependant trouvé un moyen de le définir par défaut.
Il faut créer pour le user le fichier ~/.config/xfce4/helpers.rc ou modifier /etc/xdg/xfce4/helpers.rc et mettre comme contenu (au passage j’ai aussi ajouté Firefox) :

WebBrowser=firefox
TerminalEmulator=custom-TerminalEmulator

Il faut ensuite créer le fichier ~/.local/share/xfce4/helpers/custom-TerminalEmulator.desktop avec comme contenu :

[Desktop Entry]
NoDisplay=true
Version=1.0
Encoding=UTF-8
Type=XFCE-Helper
X-XFCE-Category=TerminalEmulator
X-XFCE-CommandsWithParameter=terminator "%s"
Icon=terminator
Name=terminator
X-XFCE-Commands=terminator

Et normalement terminator est mis par défaut.

EDIT : Après un vipup, terminator semble reconnu comme un terminal.

Il faut alors juste modifier /etc/xdg/xfce4/helpers.rc :

TerminalEmulator=terminator

A plus !


#4

Hello,

J’ai finalement abandonné ma modif précédente pour quelque chose de plus simple et bien mieux.
Voici le résultat :

Nouvel Onglet

2018-08-14%2012_01_40-HNO-W10-SOC-DAL

Préférences

2018-08-14%2012_02_34-Viperr%20%5BEn%20fonction%5D%20-%20Oracle%20VM%20VirtualBox

Addons

2018-08-14%2012_02_52-Viperr%20%5BEn%20fonction%5D%20-%20Oracle%20VM%20VirtualBox

About:config

2018-08-14%2012_03_06-Viperr%20%5BEn%20fonction%5D%20-%20Oracle%20VM%20VirtualBox

Code source d’une page

2018-08-14%2012_03_46-Viperr%20%5BEn%20fonction%5D%20-%20Oracle%20VM%20VirtualBox

Pour le userContent.css j’ai pris la version sans addons de ShadowFox disponible ICI

j’ai modifié la variable “–grey-70” par la valeur utilisée dans le thème existant (#0f0f0f).
Voici donc le fichier userContent.css avec en première partie ShadowFox et à la fin du fichier l’existant de Viperr un peu élagué :

Le lien du fichier : https://git.linuxtrack.net/Linuz/fourre-tout/blob/master/userContent.css

C’est loin d’être parfait je pense, il y a probablement des choses qu’on peut retirer de ShadowFox


#6

Nouveau petit bug. Quand on relance Openbox, le conky passe au premier plan (devant toutes les fenêtres y compris celles en plein écran :slight_smile: ).
Pour résoudre le problème j’ai modifié le script de start et stop de conky (~/.Conky/ConkyStartStop) pour qu’il accepte la commande restart. J’ai fais en sorte que la commande ne lance pas conky si il n’était pas déjà démarré, comme ça conky ne démarrera pas si quelqu’un l’avait coupé et qu’il redémarre openbox :

#!/bin/bash

start() {
	conky -c ~/.Conky/conkyrc &
}

stop() {
	pkill -f conky
}

restart() {
	if pidof conky | grep [0-9] > /dev/null
	then
		stop &&	start
	fi
}

if [ "$1" == "restart" ]
then
	restart
else
	if pidof conky | grep [0-9] > /dev/null
	then
		stop
	else
		start
	fi
fi

sleep 1 ### make less impact on the cpu 


exit

### If you would like to set your own Conky feel free to share :) ###

Ensuite j’ai modifié l’entrée Relancer du menu openbox pour le passer de Restart à Execute avec comme valeur :

sh -c 'openbox --restart && ~/.Conky/ConkyStartStop restart'


#7

Merci.
Je rappelle que Viperr ne propose pas de bugbounty


#8

Bonjour à tous et à toutes,

Fedora 29 est sortie de sa boite.

Pour mettre à jour la version 28 en 29, il convient de suivre les instructions ci-après.

Pour plus de détails, consulter mon post “Mise à jour de fedora (et dérivé : Viperr 10-fc27) en n+1 ou n+2” à l’url suivante : https://linuxtrack.net/viewtopic.php?id=2480.

Par convention, “#” signifie travail en tant que root via “su” ou “sudo”, selon la configuration de votre système. Chez moi, “Viperr fedora remix” [url]https://viperr.org/site/indexfr.html[/url] utilise “su”. Adaptez selon votre situation.

Que faire ?

Ceci !

  1. Sauvegarder votre système (pas obligatoire, mais vivement conseillé !)
  2. Mise à jour en ligne de commande :
  • Lancer la procédure de mise à jour du système d’exploitation actuellement en place sur votre poste :
# dnf upgrade --refresh

=> Ceci télécharge et met à jour / nettoie et vérifie vos paquets de la version actuellement installée sur votre poste.
=> Etape obligatoire, car vous ne pourrez pas sereinement passer d’une version “n” à une version “n+1” sans que la version “n” ne soit totalement mise à jour !

  • Installer le plugin de mise à jour de version :
# dnf install dnf-plugin-system-upgrade

=> Ceci installe un plugin de mise à jour de version qui va se charger tout seul de télécharger les paquets de la version n+1 par rapport à votre version actuellemetn installée.

  • Télécharger les paquets relatifs à la mise à jour de version
# dnf system-upgrade download --releasever=28

=> Ceci télécharge les paquets de votre nouvelle version de fedora.
=> En cas de blocage pour cause de dépendances non présentes ou de paquets abandonnés, … modifier la commande en :

# dnf -y system-upgrade download --refresh --releasever=28 --allowerasing
  • Redémarrage et installation des nouveaux paquets :
# dnf system-upgrade reboot

Après tout ceci, votre système version “n” sera entièrement mis à jour à la version “n+1” , c’est-à-dire à la version 29, si vous êtes parti d’une version 28.

Dans le cas où vous seriez actuellement en version 27, il vous faudra absolument dans un délai assez bref (un mois maxi jusqu’à la suppression des dépôts 27 par fedora) mettre à jour de version de 27 à 28, puis de 28 à 29 en mode saute-mouton.

WARNING : Dans tous les cas, n’oubliez pas de disposer d’une connexion internet sûre et d’une alimentation électrique parfaite. Pour les portables, débrancher la batterie et basculer sur le réseau edf. Afin de ne pas planter vos deux mises à jour (de paquets en premier, puis de version en second). Dans le cas où la procédure serait interrompue lors du téléchargement des paquets ou de la version : pas de problème. On recommence à l’étape interrompue et cela redémarre comme si de rien était. dans le cas d’une interruption lors de l’installation des paquets ou de la version. Il y a peu de chances que vous puissiez redémarrer votre machine.

Pensez à sauvegarder impérativement vos données. c’est ce qu’il y a de plus important sur un ordinateur !

Bonne mise à jour de paquets, puis de version

Mr. S.


#9

Je corrige une faute d’inattention.

Bien évidemment il faut changer # dnf system-upgrade download --releasever=28 en # dnf system-upgrade download --releasever=29
et # dnf -y system-upgrade download --refresh --releasever=28 --allowerasing en # dnf -y system-upgrade download --refresh --releasever=29 --allowerasing pour passer d’une version 28 à 29

J’ai été un peu rapide dans ma rédaction !

Bien à vous.

Mr. S.